2013年1月3日星期四

安裝 Apache Flex SDK 4.9

Ticore's Blog

Flex SDK 4.9 是正式成為 Apache Flex 後第一個發布的版本
由於 AIR SDK 相關的部分不包含在內,需要自行手動安裝
以下做個紀錄

  1. 先分別下載好 Apache Flex 4.9 BinaryAIR SDK
  2. 個別解壓縮之後,Merge 到同一目錄下,目錄名稱可以取作 4.9.0
  3. 於 \frameworks 目錄下找到 flex-config.xml 檔案
    將所有 {playerglobalHome} 字串改為 libs/player
  4. 於 \frameworks 目錄下找到 air-config.xml, airmobile-config.xml 兩個檔案
    將所有 {airHome}/frameworks/libs/air 字串改為 libs/air
  5. 於 \frameworks 目錄下執行 ant thirdparty-downloads
    下載其它依賴的 library,包含 osmf, swfobject, flex-messaging-common,....
    中間需要回答 Y 同意授權才會繼續下載
    最大的一包是舊版的 Flex SDK,覺得下載太慢可以預先下載好
    放置到 \4.9.0\in\flex_sdk_4.6.0.23201B.zip 才執行 ant
    速度會快很多
  6. 最後打開 Flash Builder,於 Preferences \ Flash Builder \ Installed Flex SDKs
    加入剛剛的目錄位置即可

需要注意的是 AIR SDK 內只有帶一個版本 playerglobal.swc
假如編譯出現找不到 playerglobal.swc 錯誤訊息
修改專案屬性的 Flash Player Version 或是 自行手動添加該版 playerglobal.swc
關閉 project 然後重開再編譯一次即可

相關連結:
How to install Apache Flex 4.8.0 SDK in Flash Builder


轉載請註明出處 http://ticore.blogspot.com/2013/01/apache-flex-sdk-49.html

0 意見 :